[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

openvpn kaos



Hej Group

Jeg sidder og leger med en openvpn opsætning over en wan connection
men er løbet ind i et lille problem
jeg kan ikke nå mit server subnet fra clienten
jeg kan pinge fra clienten til serveren
men ikke fra clienten til de øvrige maskiner på server nettet

min server ligger på en seperat box bag min wan gateway og hedder
192.168.1.1 og min gateway hedder 192.168.1.254
tun0 hedder 10.8.0.1
så har jeg en anden box på dette net 192.168.1.49

min client ligger naturligvis også bag en wan gateway
min client hedder 192.168.0.2 og min gateway hedder 192.168.0.1
tun0 hedder 10.8.0.2


jeg kan pinge fra min client 192.168.0.2 til min server på 192.168.1.1 men ikke til 192.168.1.49 ??? jeg har sat ip_forward til 1 men kan forstå mit problem er med en route, jeg fatter bare ikke hvordan? citat fra http://openvpn.net/static.html ---snip--- Allow client to reach entire server subnet:

Suppose the OpenVPN server is on a subnet 192.168.4.0/24. Add the
following to client configuration:

    route 192.168.4.0 255.255.255.0

Then on the server side, add a route to the server's LAN gateway that
routes 10.8.0.2 to the OpenVPN server machine (only necessary if the
OpenVPN server machine is not also the gateway for the server-side LAN).
Also, don't forget to enable IP Forwarding on the OpenVPN server machine.
---snip---


#min server config: dev tun ifconfig 10.8.0.1 10.8.0.2 secret /etc/openvpn/static.key comp-lzo keepalive 10 60 ping-timer-rem persist-tun persist-key user nobody group nogroup #daemon route 192.168.1.0 255.255.255.0


#min client config: remote nethost.dk dev tun ifconfig 10.8.0.2 10.8.0.1 secret static.key route 192.168.1.0 255.255.255.0 comp-lzo keepalive 10 60 ping-timer-rem persist-tun persist-key route 192.168.1.0 255.255.255.0

er det en route command jeg skal fyre af på serveren (hvilken/hvordan)
eller er det et statement i server config filen der mangler at blive sat


Hilsen Lasse


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2006-09-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *