[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Routing mellem subnets



Hej,

Jeg har to subnets sat op på samme NIC på en server:
eth0:    ip: 10.0.1.1 netmask: 255.255.255.0
eth0:1:  ip: 10.0.2.1 netmask: 255.255.255.0

Serveren kan fint se klienter i begge subnets, f.eks. 10.0.1.5 og 10.0.2.3, og de kan ikke se hinanden. Min ADSL router står på 10.0.1.2 og serveren taler fint med nettet via en route:
# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
[...]
default 10.0.1.2 0.0.0.0 UG 0 0 0 eth0


Klienterne på 10.0.x.* er sat op med gateway=10.0.x.1, men kan ikke komme på internettet. Hvordan gør jeg det? Noget IPtables? /proc/sys/net/ipv4/ip_forward er sat til 1

Jeg er ikke interesseret i at pege dem direkte over på ADSL routeren, f.eks. med en 255.255.0.0 netmask (vil gerne kunne firewall'e).

# uname -a
Linux filserver 2.6.16-2-686-smp #2 SMP Tue May 23 07:44:59 CEST 2006 i686 GNU/Linux



Tak!

mvh
Martin Seebach


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2006-08-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *