[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

openvpn, tor og gateway på WRT54G



I forbindelse med, at jeg er ved at skifte ISP, sidder jeg og leger lidt
rundt med openwrt på min WRT54G som skal agere router til den nye ISP.
Som router fungerer den fint.

Jeg har prøvet at installere openvpn på WRT'en som server og så en
klient her på "indersiden" af routeren, efter følgende opskrift fra pkt
4.4 og ned efter :

http://wiki.openwrt.org/HotspotOpenvpnHowto?highlight=%28openvpn%29

Det så ud til at fungere fint. Men så lukkede jeg klienten ned og
kommenterede de tre ekstra linier ud i firewallen på WRT'en, og
genstartede. Herefter ved ping til 192.168.3.1 svarer den. Uden klient,
på mit interne subnet der ligger på 10.1.1.x. Jeg blev lidt forundret.
ssh kan også gå ind på adressen. Se, så blev jeg pludselig skeptisk og
lukkede openvpn ned på WRT'en. Og ping var ikke længere muligt.

Er der nogen der kan hjælpe med en forklaring på den opførsel ?

Jeg har ligeledes installeret tor. Skal den bare installeres og startes.
Og så kører det ?

Og nu det allersidste dumme spørgsmål. Ved portforwarding fra routeren
med iptables gør jeg således :

iptables -t nat -A prerouting_rule -i $WAN -p tcp --dport 80 -j DNAT
--to 10.1.1.16
iptables        -A forwarding_rule -i $WAN -p tcp --dport 80 -d
10.1.1.16 -j ACCEPT

Det fungere fint når 10.1.1.16 har gateway sat til WRT'en. Men ikke ved
andre gateway-adresser. Skal det fungere sådan ?

med venlig hilsen

Lars Brandi Jensen


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-09-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *