[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Fejl Nvidia-drivere



Jeg har lige installeret linux og da jeg har et Geforce 2 Mx grafikkort vil 
jeg gerne installere Nvidias drivere. Da jeg har installeret Slackware 
(version 8.0) downloadede jeg tar.gz udgaven af Nvidia-driverne (version 
1.0-1541). Efter at have udpakket driverne compilede jeg kernel-delen med 
kommandoen:

make install SYSINCLUDE=/usr/src/linux-2.4.5/include

Outputtet var:

rm -f nv.o os-interface.o os-registry.o  Module-linux NVdriver
cc -c -Wall -Wno-unknown-pragmas -Wno-multichar -O -D__KERNEL__ -DMODULE 
-D_LOOSE_KERNEL_NAMES -D_X86_=1 -Di386=1 -DUNIX -DLINUX -DNV4_HW -DNTRM 
-DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES   
-DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=1541  -I. 
-I/usr/src/linux-2.4.5/include nv.c
cc -c -Wall -Wno-unknown-pragmas -Wno-multichar -O -D__KERNEL__ -DMODULE 
-D_LOOSE_KERNEL_NAMES -D_X86_=1 -Di386=1 -DUNIX -DLINUX -DNV4_HW -DNTRM 
-DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES   
-DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=1541  -I. 
-I/usr/src/linux-2.4.5/include os-interface.c
cc -c -Wall -Wno-unknown-pragmas -Wno-multichar -O -D__KERNEL__ -DMODULE 
-D_LOOSE_KERNEL_NAMES -D_X86_=1 -Di386=1 -DUNIX -DLINUX -DNV4_HW -DNTRM 
-DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES   
-DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=1541  -I. 
-I/usr/src/linux-2.4.5/include os-registry.c
ld -r -o Module-linux nv.o os-interface.o os-registry.o
ld -r -o NVdriver Module-linux Module-nvkernel
size NVdriver
   text    data     bss     dec     hex filename
 580101   33760   52396  666257   a2a91 NVdriver
depmod: *** Unresolved symbols in /lib/modules/2.4.5/kernel/video/NVdriver
/lib/modules/2.4.5/kernel/video/NVdriver: unresolved symbol __global_cli
/lib/modules/2.4.5/kernel/video/NVdriver: unresolved symbol tqueue_lock
/lib/modules/2.4.5/kernel/video/NVdriver: unresolved symbol 
__global_save_flags
/lib/modules/2.4.5/kernel/video/NVdriver: unresolved symbol 
__global_restore_flags
/lib/modules/2.4.5/kernel/video/NVdriver: insmod 
/lib/modules/2.4.5/kernel/video/NVdriver failed
/lib/modules/2.4.5/kernel/video/NVdriver: insmod NVdriver failed
make: *** [package-install] Error 255

Jeg skulle måske lige bekræfte at jeg kører med linux-kernen version 2.4.5.
jeg har prøvet at køre insmod NVdriver men får hver gang den samme fejl. Også 
selvom jeg skriver:
cd /lib/modules/2.4.5/kernel/video/
insmod ./NVdriver

Jeg har prøvet at kigge på hjælp-filen på Nvidias hjemmeside. I 
troubleshooting-delen står der at problemet højst sandsynligt skyldes at 
programmet compiles med de forkerte kerne-headerfiler. Dette kan dog ikke 
passe i mit tilfælde hvor jeg netop bruger 
SYSINCLUDE=/usr/src/linux-2.4.5/include for at sikre mig at de rigtige 
header-filer vælges.

Jeg håber ikke at brevet er for langt. Jeg ville være sikker på at have alle 
informationer med.

På forhånd tak.



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 20:50 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *