[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

problem med att boota linux på at91rm9200ek mha icd



Hej!

Jag håller för tillfället på att arbeta med ett referensekort från
Atmel (at91rm9200ek), som har en at91rm9200 SoC på sig.

För att kunna debugga så använder vi en in-circuit debugger.
När vi använder debuggern så använder vi ingen boot-loader, utan vi
sätter själva upp register och aktiverar sd-ram kontrollern från
debuggern.

Därefter så laddar vi in vmlinuz tilll början på sd-ram minnet sätter
programräknaren till sd-ram + 0x8000.

Root-filesystemet ligger i en gz-komprimerade image som vi också
laddar in i sd-ram.

Kärnan ser ut att boota fint, men när den börjar exekvera /bin/init så
får kärnan ett halt-interrupt och det ser ut som det minnesområde som
kärnan är inmappad på 0xc0000000-... inte längre mappas in de fysika
adresserna.

När vi bootar med u-boot så fungerar allting (med kärnan i en
zImage). Vi har tittat på dels u-boots källkod och Atmels exempel kod
för att säkerställa att vi gör all initering görs korrekt från
debuggern.


Det är inte någon som råkar gissa på vad vi har gjort fel?

hälsningar
Håkan


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2006-02-01, 02:01 CET [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *