[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [CPROG] g++ 3.1 eller 3.2 på redhat 7.2 ???



Hej Klaus

Tak for en opskrift og en henvisning til 
ftp://ftp.funet.fi/pub/mirrors/ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS

Jeg har prøvet ihærdigt, men ...

Tilbage til mine problemer med at installere G++ 3.1 eller 3.2 VED SIDEN AF
redhat 7.3 (jeps, jeg skrev forkert første gang) standard kompiler g++ 2.96.

Efter en bunke updates på diverse binutils og clibs og alt muligt andet fra den finske rawhide spejl, er jeg kommet her til:


sslug@sslug srpms]# rpm --rebuild gcc-3.2-4.src.rpm 
Installing gcc-3.2-4.src.rpm
error: failed build dependencies:
        gcc-gnat >= 3.1 is needed by gcc-3.2-4
        libgnat >= 3.1 is needed by gcc-3.2-4


Nå, så må vi hellere få fat i gcc-gnat og libgnat. Hvad laver de egentlig ??


sslug@sslug rpms]# rpm -Uvh libgnat-3.2-4.i386.rpm gcc-gnat-3.2-4.i386.rpm 
error: failed dependencies:
        libgcc_s.so.1   is needed by libgnat-3.2-4
        libgcc_s.so.1(GCC_3.0)   is needed by libgnat-3.2-4
        libgcc_s.so.1(GLIBC_2.0)   is needed by libgnat-3.2-4
        gcc = 3.2-4 is needed by gcc-gnat-3.2-4


Nu sidder jeg der med håret i postkassen: gcc-gnat har brug for gcc, som har brug for gcc-gnat, som har ....


For at gøre det helt perfekt, findes libgcc_s.so i pakken   libstdc++, men 


sslug@sslug rpms]# rpm -Uvh --test libstdc++-3.2-4.i386.rpm libstdc++-devel-3.2-4.i386.rpm 
error: failed dependencies:
        libgcc_s.so.1   is needed by libstdc++-3.2-4
        libgcc_s.so.1(GCC_3.0)   is needed by libstdc++-3.2-4
        libstdc++ = 2.96 is needed by gcc-c++-2.96-112
        libstdc++-libc6.2-2.so.3   is needed by autorun-2.73-1
        libstdc++-libc6.2-2.so.3   is needed by doxygen-1.2.14-4
        libstdc++-libc6.2-2.so.3   is needed by groff-1.17.2-12
        libstdc++-libc6.2-2.so.3   is needed by Omni-0.5.1-3
        libstdc++-libc6.2-2.so.3   is needed by licq-1.1.0-0.cvs20020416.1
     
plus cirka 120 andre konflikter ....


HUGH???

Jeg troede i min stille naivitet at man bare kunne installere g++ 3.1 eller 3.2 VED SIDEN AF distributionens standard compiler, uden at røre en eneste 
af de ellers installerede pakker!!

Det kan man ellers på Debian uden et blink med øjene.

Hvordan løser man dette problem på en RPM baseret distribution ???

mange hilsen, Marc Cromme 


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 20:09 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *