[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [CPROG] Noget om @ i filnavne



In article <sslug@sslug> you wrote:

> Det er naturligvis gcc jeg bruger sammen med glibc2 og det er ikke et
> compiler-problem, men et problem med det færdige program. Jeg slipper
> for / i filnavnene ved at anvende dem CGI-kodede (Commom Gateway
> Interface, noget der bruges i web-servere). Her kodes en "/" som "%2f",
> altså dens hex-kode og det er tilladt i filnavne. Problemet er kun "@",
> som jeg overvejer selv at kode om til "%40", selv om det ikke ville være
> standard-CGI, men detteher er internt i mit programsystem. Det er KUN
> filnavne med den "@" indeni der ikke vil åbne.

Er det i URL du er i tvivl om de gyldige navne eller for
at åbne filer ?

For der er ikke problemer med filnavne som "sslug@sslug" i linux.

Men se bla. rfc1945 og 2068 for hvilke tegn er gyldige i URL.
Bla. er "@" i kategorien reserverede tegn, men skulle ikke ummidelbart
give problemer med browsere.

Har du kontrolleret at filnavnet er ok?, så prøv en debug udskrift af 
filnavn før åbning af filen. Måske er det slet ikke det rigtige filnavn
eller filnavnet er ikke afsluttet korrekt.
Desuden husk at lukke filen, ellers er det ikke sikkert at den oprettes.


-- 
mvh Frank Damgaard  | http://home3.inet.tele.dk/frda/



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 20:08 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *