[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Sv: [CPROG] HTTP-response



Jeg ved ikke om det hjælper, men laver man noget HTML i perl, skal man altid
skrive "\n\n" (altså to) efter "Content-Type: text/html", eller skulle den
vist også brokke sig....har dog ikke prøvet :-)

/Dennis

-----Oprindelig meddelelse-----
Fra: Thomas Lesvang <sslug@sslug>
Til: sslug@sslug <sslug@sslug>
Dato: 10. februar 1999 15:14
Emne: [CPROG] HTTP-response


>Hej
>
>Jeg sidder og roder med mit lille serverprogram. Jeg kan fint få det til at
køre når jeg bruger GET, altså i en HTML-form skriver method="GET"... Det
virker i både Netscape og Internet Explorer.
>
>Problemet kommer når jeg prøver at bruge POST, så staller IE fuldstændig.
Netscape lader sig ikke skræmme, men IE påstår serveren (mit program) har
returneret et ugyldigt svar.
>
>Jeg har læst og læst om hvordan sådan et svar skal se ud, men jeg må overse
noget for det virker ikke :-(
>
>Jeg prøver med:
>
>HTTP/1.0 200 Document follows(\n)
>Server: TEST/0.1(\n)
>Content-Type: text/html(\n)
>Content-Length: 4(\n)
>(\n)(\r)
>TEST
>
>Jeg har som afslutning af headeren prøvet med \n\n, \r\n, \n\r men det
hjælper intet. I RFC står der CRLF, hviklet må være \n\r?
>
>Er der nogen som ved hvorfor Netscape godtager ovenstående men ikke IE?
>
>Mvh
>Thomas
>
>




 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 20:07 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *